Some recent problems with my BBB rooms


I’ve recently started to try to use my BBB rooms again after a long while of not using it… But I am running into a few issues.

The primary issue is that the echo test fails when I enter my rooms using chrome, and I can’t connect the mic or talk to anyone. Here is a screenshot: the upper right shows “call timed out: error 1006”

This means anyone like me who uses chrome can’t participate in any of my rooms. I tested firefox and it worked, but I haven’t tried to look into what this error code is about.

The other issues are small, and I don’t really know if there is a simple fix:

One is that everybody has to accept that the call will be recorded before they enter the room, even if I have no intention of recording. This will deter a lot of people from ever wanting to enter rooms I share because they don’t want to be recorded. Can this maybe be turned off or disabled, or at least reworded so that it doesn’t make it seem like the call will be recorded, maybe saying something like the call "might "be recorded?

The third issue is mostly just a curiosity. Am I able to change the default PDF that is shown in every one of my rooms, or turn off having a default PDF showing entirely? The slide deck is useful in some cases, but there are other times where I’d just rather have no slide show by default, or change what is shown in a room.

Hi Robert,

  1. on Chrome - thanks for pointing this out…
    I’m using Version 96.0.4664.55 (Official Build) (x86_64) on Mac and it works for me…
    I think this may be due to your version of Chrome, or because you have previously disabled mic access. If you could check your tab has access to the mic in chrome and re-enable it, I think it should work.

  2. “everybody has to accept that the call will be recorded before they enter the room”
    Good idea to change this text - @Yurko do you know if this something we can do easily?

  3. You can set your own default presentation per room: click upload presentation, upload your PDF, then set it as the default

I hope that helps!?


We had the same observation and conversation internally at Hypha about the wording. The change would require a modification to the green light instance. I think @dvdjaco would have better insight into how difficult it would be to modify our greenlight containers.

Internally we decided to just create two rooms, one with out recordings enabled one with.

1 Like

Another trick is uploading a “broken” pdf. For example a small JPG file renamed as “.pdf”.

This will cause BBB to not be able to load the file, and as a result not show a default presentation at all.

1 Like

thanks for the help and pulling others in. the replies to what you labelled 2 and 3 are good thanks! :slight_smile:

But I am still not able to connect my mic. I checked and the app does have permission to access my mic, but it is still timing out with error 1006. Here is another screenshot showing that BBB has access to my mic theoretically


the audio connection probs remain, on both servers, as is reported by and in the support email by various members; and at yesterday’s commons.hour we had one participant who really couldn’t join (de server). Maybe the TUN server? In any case it requires urgent action, @Yurko @dvdjaco help!

@dvdjaco from the just replies internally:

yes, we’re aware of the issue and trying to debug it, > but we haven’t been able to reproduce it so far. From what I can gather from our users’ reports and from other people who have had this issue (see eg Getting error Call timeout 1006 when setup behind the firewall(corporate network) · Issue #11128 · bigbluebutton/bigbluebutton · GitHub) this error can be cause by a number of issues, including networking, server side and client side issues.

The fact that most users are not experiencing this problem seems to point to a client-side issue. On some bug reports, people have been able to reproduce the problem with a specific browser version, and have been able to work around it by upgrading the browser or switching to another one.

If someone here is able to reproduce it, it would be helpful to have: @bhaugen and anyone else who has experienced this audio connection issue (1006) in the last days, please let us know as much details as you can so we track down the issue. if you could try again to reproduce the error and with that same computer / browser / connection do the webRTC check and send us the details to or here, that would be really helpful. TIA

It’s definitely a client-side issue but might have a server-side component. I tried a bunch of browser and audio device combinations and Firefox worked with all the audio devices. Chrome did not work with any of them.

One clue is that Firefox presented me with a dialog box to allow it to use my audio and video devices, and then the echo test worked. Chrome did not present the dialog and the echo test timed out.

However, chrome has worked with BBB in the past, and this blog post Fixing your BigBlueButton audio issue | Chad's Programming Blog suggests that it might be connected to a recent BBB server software uipdate.

thanks Bob for reporting and being patient while the looks into this. Strangely all ops members so far haven’t been able to reproduce this in Chrome. That blog post is from a long time ago I’d say.

What is your precise Chrome version and on what Operating System is it?

I just wanted to mention, that I think I experienced this last night. Was using to chat with some friends. Three users total. I was fine. (Running Vivaldi from KDE Neon Linux). The other two users were using Chrome from Windows. They consistently kept timing out on the echo voice test, and if they skipped it could not get their Mic’s connected.

Switching to Microsoft Edge cleared the issue for both of them. I’m asking them both for their current versions of chrome and will provide it when I get it.

Both windows users were running Chrome 96.0.4664.110 official build 64 bit

1 Like

I’ve been getting the same - same Chrome version on an intel thingie running windows stuff:
Chrome 96.0.4664.110 official build 64 bit
Windows 10 Home v21H1

1 Like

The root of the issue does seem to be some sort of change in chrome. Below is a thread has been started to communicate our findings and actions we are taking.

Thank you everyone for providing feedback that help us diagnose what is happening!

Same issue on Chromebook with version Version 96.0.4664.111 (Official Build) (64-bit) just FYI

Thank you for hunting it down!

1 Like

I have created a test room on the new server we are working on.
If you are having issues can you please test this link below and report if it is working for you there?


Update: has been migrated to the new 2.3 server and more powerful hardware. The issues with connectivity should be gone now! is a bit more tricky to deal with and we are actively following several paths to get it done, and see which one will be the quickest. is still up with open registration for those that suffer from this issue on the CA server and need a working instance.

1 Like

Last note on this thread.

Issue has been mitigated. Additional information on this issue will be updated on this thread.