An "Incident" with test Hypha BBB - no voice


I tried using test BBB from Hypha ( - Thank you so much for this BTW!!) just now with about 10 or less participants. We tried twice but each time, the we lost audio very quickly.

Would you like to investigate? (Maybe I can help too) The incident occurred around 06:00JST, or about 110 minutes before this posting.

We had to revert to our “backup” Zoom session

1 Like

I looked at the monitoring results. Don’t see anything in the logs.

The only thing i can see was a CPU spike around the time the meeting started and continued until it ended. However it only registered 4 participants which is very odd.

The virtual service has 8 vCPUs assigned to try to mitigate this kind of behavior.

In contrast to your experience, - Thursday we had a 11 person meeting 7 video sources, 10 audio and CPU load only hit ~ 3.0 load. (We did have trouble sharing GOOGLE EARTH PRO as a screen share)

Observed from the described incident above.

:warning: CPU Load according to Linux did not exceed 6.0. Still high but not critical
:x: : Hypervisor showed ~80-90% cpu usage on guest
:white_check_mark: Physical machine CPU usage did spike but stayed under 80%
:white_check_mark: Guest disk spike in usage ~32KBps but latency was under 8ms max
:white_check_mark: Host disk spike at the time ~500KBps but latency was under 8ms max
:white_check_mark: Bandwidth was 150/425 KBps (in/out)
:white_check_mark: RAM was at 10% of 16GB

Honestly not sure what could have caused this.

Other details

Occurrence 05:55 JST - 6:10 JST = 4:55 p.m EST - 5:05 EST
Host used iPhone to start meeting
Video continued to work
Monitoring shows 4 people (Need to confirm)
Echo Test completed fine
Audio exists for the first few mins before cutting out

Possible issue suggested

The overall CPU usage should stay below 70%. If the overall CPU usage consistently stays above 70%, you’ll likely get audio troubles as the BigBlueButton server will not have enough available CPU to keep up with the audio packets.

Analysis - I can only speculate that something happens on the guest machine to cause the CPU to spike affecting the audio. Currently no evidence of what that was.


Server was not restarted or touched in anyway.

had a meeting this morning with 3 camera 4 audio and 2 listen only. Load did not exceed 0.4.

So I’m not sure what happened yesterday.

1 Like


We have just had a successful BBB session with 7 or so participants - it worked fine!

Except, that is, when I used my Bose NC700 headset connected to Windows 10.

When I did that, I could not hear anyone. The problem was fixed, after pairing the same headset with Linux.

So maybe the problem is unreliable headset pairing with Windows and IPhone? (Last time, I used IPhone) I noticed that Linux uses something called HFP to pair the headset (the sound quality is very basic - like an old phone or walkie-talkie) - maybe that helps?

The thing is, I use my headset (Bose NC700) all the time with my Iphone for regular phone calls and and I have never had any problem like ‘no sound’…

After the June 11 open 2020 conference, perhaps we should invite all of our friends have a chit-chat party or something to test variety of use cases?

There is another update:

After trying various things the following became clear:

  • BBB from my Iphone (with Safari web browser) was constantly losing audio, while microphone continued to work (Other people could hear my but I could not hear them)

  • No remedy worked until I cleared the cache of the said Safari web browser!