Error while trying to connect video

Hi all,

So my first meeting on was a bit of a bust – I got the following error trying to turn my video camera on, any idea what’s up? Or what other information would help diagnose?

Screenshot 2020-08-02 at 4.00.53 PM

Thank you!

Hi @caseyg. That error points to a problem with the network connection. Could you try BigBlueButton on the official demo site and see if you get the same error? What browser are you using? Please also do the WebRTC test and post results here.

Thanks @hng.

Same error on the demo server. Browser is Safari Version 13.1.1 (15609. on Mac OS 10.15.5 (19F101).

The WebRTC test stopped working here… is Safari not supported?

Screenshot 2020-08-04 at 5.53.11 PM

Hi @caseyg,

I have just started my test server (sending you the link directly) - does this work?

@Yasuaki I was able to connect on your server from the same browser (Safari Mac OS X)

1 Like

Thank you @caseyg,

I also confirm that our demo server gives me the same message you saw on (I used my Iphone’s Safari)


1 Like

Although cannot directly verify the status of the server, I believe your posting and sorry, I don’t have admin access to the server right now…

We will have a technology circle meeting today so this will definitely be discussed.

I wonder if all we need is a server reboot or if this is specific to BBB version… Let me cbeck

1 Like

Using the exact same Internet connection, I can connect to from my Windows 10 laptop (Surface) but Not from Iphone…

I also tried the “Private Browsing Mode” of Iphone to eliminate caching problems - I still received the same error message

1 Like

@caseyg Safari is sometimes a bit wonky, could you please try again with Chrome(ium)? It’s working for me with Safari so it looks like a Safari and networking problem on your side. Could you also check whether you may have an IPv6 only connection? E.g. here: (please don’t post your IP address here)

I can also reproduce on, this looks to me like a problem with the TURN server…

I can also reproduce the same error on Safari, when on Firefox it works fine, both on the production instance at

Strangely on another instance, I get a different error error 2203 related to codec, while on Safari.

More info:

From my Iphone:

Yasu personal dev BBB server -> OK
ColloCall BBB -> OK
Hypha BBB -> OK -> Failure

So it only fails on a specific condition:

  • Client is Safari
  • Server is (I have not tested but probably as broken as is what @hng and I tested on Safari, and confirmed the reported problem.

So Hypha BBB is what gave me the error 2203 on Desktop Safari. I don’t want to distract this convo though, as Hypha BBB is probably running another version of BBB.

So because no one noticed this until now, I guess all of us use either Windows or Linux and not Macintosh? :smile:

Or with Chrome/Firefox on macOS :wink: In general it is known that Safari is not the best browser for WebRTC, quite some video conf systems don’t recommend or don’t work with Safari on macOS.

That’s interesting because BBB says, when accessed from non-Safari browser running on Iphone, ‘Only Safari Browser Is Supported’ :sweat_smile:

On iPhone it is the other way around. In general BBB should work fine with Safari but there are often problems like these.

I also tried to have my first meeting on today but the first person who tried to join did so on an iPhone (I assume using Safari) and it didn’t work so we abandoned and went back to Zoom :confused:

Sorry for this, there will be an all-hands meeting today and this will be discussed.

From the tech meeting yesterday, the most suspected cause is that the particular version or configuration we have on BBB at is incompatible with Safari browser and because BBB rejects non-Safari browser running on IPhone, we are stuck right now.

1 Like

Hey yall. This error is coming up for me.
I was using Big Blue Button successfully for a year (starting in Spring 2020). Then, sometime in Spring 2021, my video stopped working. This error consistently comes up: Media could not reach the server (error 1020).
I have this problem and this error across platforms and browsers: iPhone 12 (iOS 14.7.1), an iPad 2 (I think also running iOS 14.7.1, I could check), and a MacBook Pro (mid-2015, running Catalina, OS 10.15.7). I tried Safari, Chrome, and Firefox. I mostly use WiFi directly (and I’ve tried hotspots and cellular connections).
I am guessing the problem is network-related, but I really do not know.
EDITTING TO ADD: I just went to the test site for BBB, and my video worked. Now, what does that mean I need to do to get BBB video to work on the regular?!
Is there a better place to post my question? has this problem posted by multiple members; the answers have been too technical for me.
I would appreciate any advice to solve my video issues.

  • Caitlin